summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/reaktor2.nix
diff options
context:
space:
mode:
authorRTUnreal <unreal@rtinf.net>2022-12-27 22:02:20 +0100
committerlassulus <lassulus@lassul.us>2022-12-27 22:08:15 +0100
commitce2ec4448079b39842a740a2d40249e2498df012 (patch)
tree820556b01b102b8fb59f0a5d78be244d1002ad86 /krebs/2configs/reaktor2.nix
parent6648ea3cebb659404841a4c4a29de83e800b23b9 (diff)
reaktor2: add del alias for delete
Diffstat (limited to 'krebs/2configs/reaktor2.nix')
-rw-r--r--krebs/2configs/reaktor2.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/krebs/2configs/reaktor2.nix b/krebs/2configs/reaktor2.nix
index 9bcee6fb..11aaf876 100644
--- a/krebs/2configs/reaktor2.nix
+++ b/krebs/2configs/reaktor2.nix
@@ -146,7 +146,7 @@ let
command = 1;
arguments = [2];
env.TASKDATA = "${stateDir}/${name}";
- commands = {
+ commands = rec {
add.filename = pkgs.writeDash "${name}-task-add" ''
${pkgs.taskwarrior}/bin/task rc:${taskRcFile} add "$1"
'';
@@ -159,6 +159,7 @@ let
delete.filename = pkgs.writeDash "${name}-task-delete" ''
${pkgs.taskwarrior}/bin/task rc:${taskRcFile} delete "$1"
'';
+ del = delete;
done.filename = pkgs.writeDash "${name}-task-done" ''
${pkgs.taskwarrior}/bin/task rc:${taskRcFile} done "$1"
'';