summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/reaktor2.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-11-21 15:29:07 +0100
committerlassulus <lassulus@lassul.us>2022-11-21 15:36:26 +0100
commitbe3762d35106bff34c24987fdc2c3fc3d44a54c5 (patch)
treebce8bba35cd8623d5b86b2b50c29d597c8d0dfc2 /krebs/2configs/reaktor2.nix
parentb2f8ffb920466663f6b48b1cefcbf336b700bff4 (diff)
reaktor2: add !confuse
Diffstat (limited to 'krebs/2configs/reaktor2.nix')
-rw-r--r--krebs/2configs/reaktor2.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/krebs/2configs/reaktor2.nix b/krebs/2configs/reaktor2.nix
index 3dc3ce0a..6768a200 100644
--- a/krebs/2configs/reaktor2.nix
+++ b/krebs/2configs/reaktor2.nix
@@ -51,6 +51,29 @@ let
};
};
+ confuse = {
+ pattern = "^!confuse (.*)$";
+ activate = "match";
+ arguments = [1];
+ command = {
+ filename = pkgs.writeDash "confuse" ''
+ set -efu
+ export PATH=${makeBinPath [
+ pkgs.coreutils
+ pkgs.curl
+ pkgs.gnused
+ pkgs.stable-generate
+ ]}
+ stable_url=$(stable-generate "$@")
+ paste_url=$(curl -Ss "$stable_url" |
+ curl -Ss https://p.krebsco.de --data-binary @- |
+ tail -1
+ )
+ echo "$_from: $paste_url"
+ '';
+ };
+ };
+
taskRcFile = builtins.toFile "taskrc" ''
confirmation=no
'';
@@ -218,6 +241,7 @@ let
'';
};
}
+ confuse
bedger-add
bedger-balance
hooks.sed