summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/cache.nsupdate.info.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-11-21 00:03:49 +0100
committermakefu <github@syntax-fehler.de>2018-11-21 00:03:49 +0100
commitb073ee1fd4a879a29166422269733604a6454fc3 (patch)
treea4695b1439c0f8e3138f18c680082b3e24d970da /krebs/2configs/cache.nsupdate.info.nix
parentc4bdac09dffc9830066f5662b1e741aa3d0de5a7 (diff)
puyak.r: add cache.nsupdate.info
Diffstat (limited to 'krebs/2configs/cache.nsupdate.info.nix')
-rw-r--r--krebs/2configs/cache.nsupdate.info.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/krebs/2configs/cache.nsupdate.info.nix b/krebs/2configs/cache.nsupdate.info.nix
new file mode 100644
index 00000000..056667d8
--- /dev/null
+++ b/krebs/2configs/cache.nsupdate.info.nix
@@ -0,0 +1,33 @@
+{lib, ... }:
+with lib;
+let
+ domain = "cache.nsupdate.info";
+in {
+ # This only works for a single domain for nsupdate.info as multiple usernames
+ # and passwords are required for multiple domains
+ services.ddclient = {
+ enable = true;
+ server = "ipv4.nsupdate.info";
+ username = domain;
+ password = import ((toString <secrets>) + "/nsupdate-cache.nix");
+ domains = [ domain ];
+ use= "if, if=et0";
+ # use = "web, web=http://ipv4.nsupdate.info/myip";
+
+ };
+ krebs.cachecache = {
+ enable = true;
+ enableSSL = false; # disable letsencrypt for testing
+ cacheDir = "/var/cache/nix-cache-cache";
+ maxSize = "10g";
+
+ # assumes that the domain is reachable from the internet
+ virtualHost = domain;
+ };
+
+ boot.kernelModules = [ "tcp_bbr" ];
+
+ boot.kernel.sysctl."net.ipv4.tcp_congestion_control" = "bbr";
+ boot.kernel.sysctl."net.core.default_qdisc" = "fq";
+ networking.firewall.allowedTCPPorts = [ 80 443 ];
+}