summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/buildbot-stockholm.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-09-09 10:04:13 +0200
committertv <tv@krebsco.de>2018-09-09 10:24:57 +0200
commitd3c84b0d2981f46574046e19d8e3d618065b92a0 (patch)
treee35355fc1b12d754e2c4f0710657d5673a44a7aa /krebs/2configs/buildbot-stockholm.nix
parentb7d5dbd74be88e0d26dce173b523bf5019de548b (diff)
buildbot-stockholm: build quietly and show trace
Diffstat (limited to 'krebs/2configs/buildbot-stockholm.nix')
-rw-r--r--krebs/2configs/buildbot-stockholm.nix23
1 files changed, 19 insertions, 4 deletions
diff --git a/krebs/2configs/buildbot-stockholm.nix b/krebs/2configs/buildbot-stockholm.nix
index 6555b73f..add27f39 100644
--- a/krebs/2configs/buildbot-stockholm.nix
+++ b/krebs/2configs/buildbot-stockholm.nix
@@ -12,11 +12,26 @@ let
"http://cgit.prism.r/stockholm"
];
+ # usage: build USER HOST
+ # This executable is meant to be run with <stockholm> as working directory.
+ # USER is expected to be a subdirectory of the working directory.
build = pkgs.writeDash "build" ''
- set -eu
- export USER="$1"
- export SYSTEM="$2"
- $(nix-build $USER/krops.nix --no-out-link --argstr name "$SYSTEM" --argstr target "$HOME/stockholm-build" -A ci)
+ set -efu
+
+ user=$1
+ host=$2
+
+ result=$(nix-build \
+ --argstr name "$host" \
+ --argstr target "$HOME"/stockholm-build \
+ --attr ci \
+ --no-build-output \
+ --no-out-link \
+ --show-trace \
+ "$user"/krops.nix \
+ )
+
+ exec "$result"
'';