summaryrefslogtreecommitdiffstats
path: root/jeschli/2configs/vim.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-01-28 18:32:29 +0000
committerjeschli <jeschli@gmail.com>2018-01-28 18:32:29 +0000
commiteb1ecbe5b49e74862d61e67235e9eb74862cae56 (patch)
tree068a728aa63198051a40147bb04f381f1a2134c5 /jeschli/2configs/vim.nix
parent0cad7868a46613eb76fe1a8271efe2a9230e85ad (diff)
jeschli vim: +vim-elm
Diffstat (limited to 'jeschli/2configs/vim.nix')
-rw-r--r--jeschli/2configs/vim.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/jeschli/2configs/vim.nix b/jeschli/2configs/vim.nix
index 65ce7dfa..7721b1d4 100644
--- a/jeschli/2configs/vim.nix
+++ b/jeschli/2configs/vim.nix
@@ -20,6 +20,7 @@ let
sha256 = "1z3yhhbmbzfw68qjzyvpbmlyv2a1p814sy5q2knn04kcl30vx94a";
};
};
+
in {
environment.systemPackages = [
(pkgs.vim_configurable.customize {
@@ -65,11 +66,17 @@ in {
let g:molokai_original = 1
let g:rehash256 = 1
'';
-
+ settingsForElm = ''
+ let g:polyglot_disabled = ['elm']
+ let g:elm_detailed_complete = 1
+ let g:elm_format_autosave = 1
+ let g:elm_syntastic_show_warnings = 1
+ '';
in ''
${colorscheme}
${remapStatements}
${setStatements}
+ ${settingsForElm}
${settingsForGo}
" I dont know what this line is about
autocmd BufNewFile,BufRead *.go setlocal noexpandtab tabstop=4 shiftwidth=4
@@ -85,6 +92,7 @@ in {
"surround"
"Syntastic"
"undotree"
+ "elm-vim"
];
}
{ names = [ "vim-addon-nix" ]; ft_regex = "^nix\$"; }