summaryrefslogtreecommitdiffstats
path: root/jeschli/2configs/vim.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-02-07 10:08:36 +0100
committerjeschli <jeschli@gmail.com>2018-02-07 10:08:36 +0100
commit257f91eff3cf2ef01c25f4e88d186ea30dc250f7 (patch)
tree03e8d0587c17f356f2425e682da71832071116bc /jeschli/2configs/vim.nix
parente5114f1bfb9f7f412236f05e15fb6023699c96d6 (diff)
j vim: +trailing White detection; *cosmetics
Diffstat (limited to 'jeschli/2configs/vim.nix')
-rw-r--r--jeschli/2configs/vim.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/jeschli/2configs/vim.nix b/jeschli/2configs/vim.nix
index 7721b1d4..02ea95f6 100644
--- a/jeschli/2configs/vim.nix
+++ b/jeschli/2configs/vim.nix
@@ -27,6 +27,9 @@ in {
name = "vim";
vimrcConfig.customRC = let
colorscheme = ''colorscheme molokai'';
+ highlightTrailingWhiteSpaces = ''
+ au Syntax * syn match Garbage containedin=ALL /\s\+$/
+ '';
setStatements = ''
set autowrite
set clipboard=unnamedplus
@@ -74,11 +77,12 @@ in {
'';
in ''
${colorscheme}
+ ${highlightTrailingWhiteSpaces}
${remapStatements}
${setStatements}
${settingsForElm}
${settingsForGo}
- " I dont know what this line is about
+ " dont expand tabs in go files and show it with four whitespaces.
autocmd BufNewFile,BufRead *.go setlocal noexpandtab tabstop=4 shiftwidth=4
'';
vimrcConfig.vam.knownPlugins = pkgs.vimPlugins // customPlugins;