summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/reagenzglas/hardware-configuration.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2017-12-05 21:29:45 +0000
committerjeschli <jeschli@gmail.com>2017-12-05 21:29:45 +0000
commit29f9d3b86926916df63d4525f909316df5638f86 (patch)
tree2771a340769cde5d04b79355570c0be7d375a68a /jeschli/1systems/reagenzglas/hardware-configuration.nix
parent8030352c450432a0cee14f561241831875f8399b (diff)
boom
Diffstat (limited to 'jeschli/1systems/reagenzglas/hardware-configuration.nix')
-rw-r--r--jeschli/1systems/reagenzglas/hardware-configuration.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/jeschli/1systems/reagenzglas/hardware-configuration.nix b/jeschli/1systems/reagenzglas/hardware-configuration.nix
new file mode 100644
index 00000000..a6ab3f16
--- /dev/null
+++ b/jeschli/1systems/reagenzglas/hardware-configuration.nix
@@ -0,0 +1,33 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ehci_pci" "ahci" "sd_mod" "sr_mod" "rtsx_pci_sdmmc" ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/09130cf7-b71b-42ab-9fa3-cb3c745f1fc9";
+ fsType = "ext4";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/disk/by-uuid/8bee50b3-5733-4373-a966-388def141774";
+ fsType = "ext4";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/DA40-AC19";
+ fsType = "vfat";
+ };
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 8;
+# powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}