summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/bolide/hardware-configuration.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-01-20 20:49:48 +0000
committerjeschli <jeschli@gmail.com>2018-01-21 10:16:25 +0000
commitbaf4fc520b9faae6ad07c1b9f6d6623b92768ce6 (patch)
tree176a82499fa199b65a2a4680148b8fe40f9d76d6 /jeschli/1systems/bolide/hardware-configuration.nix
parent09abdb667c4c9da77d854a10c8614c22916e639d (diff)
j: +bolide
Diffstat (limited to 'jeschli/1systems/bolide/hardware-configuration.nix')
-rw-r--r--jeschli/1systems/bolide/hardware-configuration.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/jeschli/1systems/bolide/hardware-configuration.nix b/jeschli/1systems/bolide/hardware-configuration.nix
new file mode 100644
index 00000000..183b29e4
--- /dev/null
+++ b/jeschli/1systems/bolide/hardware-configuration.nix
@@ -0,0 +1,32 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
+ boot.kernelModules = [ "kvm-intel" "wl" ];
+ boot.extraModulePackages = [ config.boot.kernelPackages.broadcom_sta ];
+
+ fileSystems."/" =
+ { device = "/dev/bolide-pool/bolide-root";
+ fsType = "ext4";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/bolide-pool/bolide-home";
+ fsType = "ext4";
+ };
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/3aeb67c4-5b6e-4df2-8013-607fe0fb8525";
+ fsType = "ext4";
+ };
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 8;
+ powerManagement.cpuFreqGovernor = "powersave";
+}