summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-10-22 20:21:01 +0200
committerlassulus <lass@aidsballs.de>2015-10-22 20:21:01 +0200
commit93dcfe5ad61903f90f422d9d6c97e499b240aa86 (patch)
treec4b642bce5969e5085431f052932ad7dc7df1761 /default.nix
parent692a59423ab3ab8fb2f5323af15cdec033d94fda (diff)
parent128e5feae9829ec1c60d16f3d44382435ff1ef86 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/default.nix b/default.nix
index c7022517..b261e51e 100644
--- a/default.nix
+++ b/default.nix
@@ -17,7 +17,8 @@
{ current-date ? abort "current-date not defined"
, current-host-name ? abort "current-host-name not defined"
, current-user-name ? builtins.getEnv "LOGNAME"
-}@current:
+, StrictHostKeyChecking ? "yes"
+}@args:
let stockholm = {
# The generated scripts to deploy (or infest) systems can be found in the
@@ -44,10 +45,10 @@ let stockholm = {
# Additionally, output lib and pkgs for easy access from the shell.
# Notice how we're evaluating just the base module to obtain pkgs.
inherit lib;
- inherit (eval {}) pkgs;
+ inherit pkgs;
};
- krebs = import ./krebs (current // { inherit lib stockholm; });
+ krebs = import ./krebs (args // { inherit lib stockholm; });
lib =
let
@@ -62,6 +63,8 @@ let stockholm = {
nspath = ns: p: stockholm-path + "/${ns}/${p}";
};
+ inherit (eval {}) pkgs;
+
# Path resolvers for common and individual files.
# Example: `upath "3modules"` produces the current user's 3modules directory
kpath = lib.nspath "krebs";