summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/shell.nix b/shell.nix
deleted file mode 100644
index 9abf4be..0000000
--- a/shell.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-
-let
- pname = "news";
- version = "1";
-
- pkgs = nixpkgs // extrapkgs;
- nixpkgs = import <nixpkgs> {};
- extrapkgs = {
- };
- hsPkgs = pkgs.haskellPackages.override {
- overrides = self: super: {
- };
- };
- hsEnv = hsPkgs.ghcWithPackages (_hsPkgs: with _hsPkgs;
- [
- bloomfilter
- irc
- irc-client
- feed
- split
- warp
- wai-util
- wreq
- ]);
-in
-
-pkgs.myEnvFun {
- name = "${pname}-${version}";
-
- buildInputs = with pkgs; [
- hsEnv
- ];
-
- extraCmds = with pkgs; ''
- $(grep export ${hsEnv.outPath}/bin/ghc)
- '';
-}
-
-# vim: set fdm=marker :