summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-07-22 23:31:40 +0200
committerlassulus <git@lassul.us>2023-07-22 23:31:40 +0200
commitcbc475bdf46c115ac0f28008a531164567a12f87 (patch)
tree951e83027f7a7172c8845515772f0c1bbd5e57ab /flake.nix
parent1c524b67279126b976165f0d4fc8e7a7f1678f7e (diff)
init flake.nixHEADmaster
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..ec13152
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,29 @@
+{
+ description = "krops - krebs operations";
+
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ };
+
+ outputs = { self, nixpkgs, ... }:
+ let
+ supportedSystems = [
+ "x86_64-linux"
+ "i686-linux"
+ "aarch64-linux"
+ "riscv64-linux"
+ ];
+ forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
+ in
+ {
+ lib = forAllSystems (system:
+ let
+ pkgs = nixpkgs.legacyPackages.${system};
+ krops = pkgs.callPackage ./pkgs/krops {};
+ populate = pkgs.callPackage ./pkgs/populate {};
+ in {
+ inherit populate;
+ inherit (krops) rebuild runShell withNixOutputMonitor writeCommand writeDeploy writeTest;
+ });
+ };
+}