summaryrefslogtreecommitdiffstats
path: root/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'types.nix')
-rw-r--r--types.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/types.nix b/types.nix
index bf9dc30..377f546 100644
--- a/types.nix
+++ b/types.nix
@@ -834,6 +834,7 @@ rec {
};
type = mkOption {
type = types.enum [ "zpool" ];
+ default = "zpool";
internal = true;
};
mode = mkOption {
@@ -1212,6 +1213,8 @@ rec {
};
type = mkOption {
type = types.enum [ "disk" ];
+ default = "disk";
+ internal = true;
};
device = mkOption {
type = optionTypes.absolute-pathname; # TODO check if subpath of /dev ? - No! eg: /.swapfile