summaryrefslogtreecommitdiffstats
path: root/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'types.nix')
-rw-r--r--types.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/types.nix b/types.nix
index 92f11fb..2ed3ccc 100644
--- a/types.nix
+++ b/types.nix
@@ -152,6 +152,7 @@ rec {
*/
zapCreateMount = devices: ''
set -efux
+ shopt -s nullglob
# print existing disks
lsblk
@@ -161,6 +162,12 @@ rec {
umount -Rlv /mnt
fi
+ # stop all existing raids
+ for r in /dev/md/* /dev/md[0-9]*; do
+ # might fail if the device was already closed in the loop
+ mdadm --stop "$r" || true
+ done
+
echo 'creating partitions...'
${diskoLib.create devices}
echo 'mounting partitions...'