summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..3e7263a
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,19 @@
+{
+ description = "Description for the project";
+
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+
+ outputs = { self, nixpkgs, ... }: {
+ lib = import ./. {
+ inherit (nixpkgs) lib;
+ };
+ checks.x86_64-linux = let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ in {
+ # Run tests: nix flake check -L
+ nixos-test = pkgs.callPackage ./tests/test.nix {
+ makeTest = import (pkgs.path + "/nixos/tests/make-test-python.nix");
+ };
+ };
+ };
+}