summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2022-08-17 14:53:51 +0200
committerJörg Thalheim <joerg@thalheim.io>2022-08-17 14:53:51 +0200
commit6b3d6452eb0ecd019468eff149b023560360e566 (patch)
tree88197df546363895dc7194d0f1722cc6e803b08f /flake.nix
parentcfd8c7ae131c3654b2895f3e84d45c40dab78c94 (diff)
add flake
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..3e7263a
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,19 @@
+{
+ description = "Description for the project";
+
+ inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+
+ outputs = { self, nixpkgs, ... }: {
+ lib = import ./. {
+ inherit (nixpkgs) lib;
+ };
+ checks.x86_64-linux = let
+ pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ in {
+ # Run tests: nix flake check -L
+ nixos-test = pkgs.callPackage ./tests/test.nix {
+ makeTest = import (pkgs.path + "/nixos/tests/make-test-python.nix");
+ };
+ };
+ };
+}