summaryrefslogtreecommitdiffstats
path: root/example/zfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/zfs.nix')
-rw-r--r--example/zfs.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/example/zfs.nix b/example/zfs.nix
index e344289..2b56bd7 100644
--- a/example/zfs.nix
+++ b/example/zfs.nix
@@ -12,11 +12,16 @@
zroot = {
type = "zpool";
mode = "mirror";
+ rootFsOptions = {
+ compression = "lz4";
+ "com.sun:auto-snapshot" = "false";
+ };
datasets = [
{
type = "zfs_filesystem";
name = "zfs_fs";
mountpoint = "/zfs_fs";
+ options."com.sun:auto-snapshot" = "true";
}
{
type = "zfs_filesystem";