summaryrefslogtreecommitdiffstats
path: root/example/lvm-raid.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/lvm-raid.nix')
-rw-r--r--example/lvm-raid.nix66
1 files changed, 66 insertions, 0 deletions
diff --git a/example/lvm-raid.nix b/example/lvm-raid.nix
new file mode 100644
index 0000000..48930ec
--- /dev/null
+++ b/example/lvm-raid.nix
@@ -0,0 +1,66 @@
+{
+ type = "devices";
+ content = {
+ vdb = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ part-type = "primary";
+ start = "0%";
+ end = "100%";
+ content = {
+ type = "lvm_pv";
+ vg = "pool";
+ };
+ }
+ ];
+ };
+ vdc = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ part-type = "primary";
+ start = "0%";
+ end = "100%";
+ content = {
+ type = "lvm_pv";
+ vg = "pool";
+ };
+ }
+ ];
+ };
+ pool = {
+ type = "lvm_vg";
+ lvs = {
+ root = {
+ type = "lvm_lv";
+ size = "100M";
+ mountpoint = "/";
+ lvm_type = "mirror";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ options = [
+ "defaults"
+ ];
+ };
+ };
+ home = {
+ type = "lvm_lv";
+ size = "10M";
+ lvm_type = "raid0";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/home";
+ };
+ };
+ };
+ };
+ };
+}