summaryrefslogtreecommitdiffstats
path: root/example/luks-lvm.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/luks-lvm.nix')
-rw-r--r--example/luks-lvm.nix130
1 files changed, 65 insertions, 65 deletions
diff --git a/example/luks-lvm.nix b/example/luks-lvm.nix
index 22c029e..17e18a2 100644
--- a/example/luks-lvm.nix
+++ b/example/luks-lvm.nix
@@ -1,81 +1,81 @@
{
- type = "devices";
- content = {
+ disk = {
vdb = {
- type = "table";
- format = "gpt";
- partitions = [
- {
- type = "partition";
- part-type = "ESP";
- start = "1MiB";
- end = "100MiB";
- fs-type = "FAT32";
- bootable = true;
- content = {
- type = "filesystem";
- format = "vfat";
- mountpoint = "/boot";
- options = [
- "defaults"
- ];
- };
- }
- {
- type = "partition";
- part-type = "primary";
- start = "100MiB";
- end = "100%";
- content = {
- type = "luks";
- algo = "aes-xts...";
- name = "crypted";
- keyfile = "/tmp/secret.key";
- extraArgs = [
- "--hash sha512"
- "--iter-time 5000"
- ];
- content = {
- type = "lvm_pv";
- vg = "pool";
- };
- };
- }
- ];
- };
- pool = {
- type = "lvm_vg";
- lvs = {
- root = {
- type = "lvm_lv";
- size = "100M";
- mountpoint = "/";
+ type = "disk";
+ device = "/dev/vdb";
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ name = "ESP";
+ # fs-type = "FAT32";
+ start = "1MiB";
+ end = "100MiB";
+ bootable = true;
content = {
type = "filesystem";
- format = "ext4";
- mountpoint = "/";
+ format = "vfat";
+ mountpoint = "/boot";
options = [
"defaults"
];
};
- };
- home = {
- type = "lvm_lv";
- size = "10M";
+ }
+ {
+ type = "partition";
+ name = "luks";
+ start = "100MiB";
+ end = "100%";
content = {
- type = "filesystem";
- format = "ext4";
- mountpoint = "/home";
+ type = "luks";
+ name = "crypted";
+ keyFile = "/tmp/secret.key";
+ extraArgs = [
+ "--hash sha512"
+ "--iter-time 5000"
+ ];
+ content = {
+ type = "lvm_pv";
+ vg = "pool";
+ };
};
+ }
+ ];
+ };
+ };
+ };
+ lvm_vg = {
+ pool = {
+ type = "lvm_vg";
+ lvs = {
+ root = {
+ type = "lvm_lv";
+ size = "100M";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ options = [
+ "defaults"
+ ];
};
- raw = {
- type = "lvm_lv";
- size = "10M";
- content = {
- type = "noop";
- };
+ };
+ home = {
+ type = "lvm_lv";
+ size = "10M";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/home";
};
};
+ raw = {
+ type = "lvm_lv";
+ size = "10M";
+ };
+ };
};
};
}