summaryrefslogtreecommitdiffstats
path: root/example/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/default.nix')
-rw-r--r--example/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/example/default.nix b/example/default.nix
index aa03d27..f2826c9 100644
--- a/example/default.nix
+++ b/example/default.nix
@@ -1,6 +1,10 @@
# usage: nix-instantiate --eval --json --strict example | jq -r .
-with import ../lib;
+let
+ # TODO: get rid of NIX_PATH dependency here
+ pkgs = import <nixpkgs> {};
+in
+with import ../lib { inherit (pkgs) lib;};
{
config = config (import ./config.nix);