summaryrefslogtreecommitdiffstats
path: root/example/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/config.nix')
-rw-r--r--example/config.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/example/config.nix b/example/config.nix
new file mode 100644
index 0000000..e9766fe
--- /dev/null
+++ b/example/config.nix
@@ -0,0 +1,57 @@
+# usage: nix-instantiate --eval --json --strict example/config.nix | jq .
+{
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ part-type = "ESP";
+ start = "1MiB";
+ end = "1024MiB";
+ fs-type = "fat32";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ };
+ }
+ {
+ type = "partition";
+ part-type = "primary";
+ start = "1024MiB";
+ end = "100%";
+ content = {
+ type = "luks";
+ algo = "aes-xts...";
+ name = "crypted";
+ keyfile = "/tmp/secret.key";
+ content = {
+ type = "lvm";
+ name = "pool";
+ lvs = {
+ root = {
+ type = "lv";
+ size = "10G";
+ mountpoint = "/";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ };
+ home = {
+ type = "lv";
+ size = "10G";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/home";
+ };
+ };
+ };
+ };
+ };
+ }
+ ];
+}