summaryrefslogtreecommitdiffstats
path: root/example/btrfs-subvolumes.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/btrfs-subvolumes.nix')
-rw-r--r--example/btrfs-subvolumes.nix43
1 files changed, 23 insertions, 20 deletions
diff --git a/example/btrfs-subvolumes.nix b/example/btrfs-subvolumes.nix
index 0124c86..83ea71e 100644
--- a/example/btrfs-subvolumes.nix
+++ b/example/btrfs-subvolumes.nix
@@ -1,25 +1,28 @@
{
- type = "devices";
- content = {
+ disk = {
vdb = {
- type = "table";
- format = "gpt";
- partitions = [
- {
- type = "partition";
- part-type = "primary";
- start = "0%";
- end = "100%";
- content = {
- type = "btrfs";
- mountpoint = "/";
- subvolumes = [
- "/home"
- "/test"
- ];
- };
- }
- ];
+ type = "disk";
+ device = "/dev/vdb";
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ name = "root";
+ type = "partition";
+ start = "0%";
+ end = "100%";
+ content = {
+ type = "btrfs";
+ mountpoint = "/";
+ subvolumes = [
+ "/home"
+ "/test"
+ ];
+ };
+ }
+ ];
+ };
};
};
}