summaryrefslogtreecommitdiffstats
path: root/types.nix
diff options
context:
space:
mode:
authora-kenji <aks.kenji@protonmail.com>2022-11-21 12:00:45 +0100
committera-kenji <aks.kenji@protonmail.com>2022-11-21 12:00:45 +0100
commit581870a4445b53945303239ef3305212c22d12a3 (patch)
tree368b8f28fa960746d864177228d639338a439556 /types.nix
parentc60f20ceffd9cd662aad8482dd1bdeed472d75c2 (diff)
fix: typos
Diffstat (limited to 'types.nix')
-rw-r--r--types.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/types.nix b/types.nix
index fe04e9c..d4d6256 100644
--- a/types.nix
+++ b/types.nix
@@ -16,7 +16,7 @@ rec {
nestedTypes = typeAttr;
};
- # option for valid contents of partitons (basically like devices, but without tables)
+ # option for valid contents of partitions (basically like devices, but without tables)
partitionType = mkOption {
type = types.nullOr (diskoLib.subType { inherit btrfs filesystem zfs mdraid luks lvm_pv; });
default = null;
@@ -138,7 +138,7 @@ rec {
sortedDeviceList = diskoLib.sortDevicesByDependencies ((diskoLib.meta devices).deviceDependencies or {}) devices;
in ''
set -efux
- # first create the neccessary devices
+ # first create the necessary devices
${concatStrings (map (dev: attrByPath (dev ++ [ "_mount" "dev" ]) "" devices) sortedDeviceList)}
# and then mount the filesystems in alphabetical order