summaryrefslogtreecommitdiffstats
path: root/types.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-10-23 11:30:08 +0200
committerlassulus <lassulus@lassul.us>2022-10-23 11:36:56 +0200
commit3c4cc930077f88fd1bb6331e26dcbcf7efa7478e (patch)
tree6db40cbdce8ebcdd82e159913a8876af26b7e835 /types.nix
parent5aa3ebcb998c1d489926e4f702ee98f5175240e6 (diff)
export config list in types
Diffstat (limited to 'types.nix')
-rw-r--r--types.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/types.nix b/types.nix
index db70ede..6c35de6 100644
--- a/types.nix
+++ b/types.nix
@@ -156,9 +156,7 @@ rec {
config :: types.devices -> nixosConfig
*/
- config = devices: {
- imports = flatten (map (dev: dev._config) (flatten (map attrValues (attrValues devices))));
- };
+ config = devices: flatten (map (dev: dev._config) (flatten (map attrValues (attrValues devices))));
/* Takes a disko device specification and returns a function to get the needed packages to format/mount the disks
packages :: types.devices -> pkgs -> [ derivation ]