summaryrefslogtreecommitdiffstats
path: root/tests/lib.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2022-08-26 08:41:58 +0200
committerJörg Thalheim <joerg@thalheim.io>2022-08-26 08:41:58 +0200
commit69f1337980756fe4ac001cadce7760e7b06c75da (patch)
tree815639ea1fa5a844f1e5fdc20010c3fbd4118e61 /tests/lib.nix
parent1ac0e76b15a3b13c83d25a78b32dee4070a584b7 (diff)
fix inconsistent indentation with nixpkgs-fmt
Diffstat (limited to 'tests/lib.nix')
-rw-r--r--tests/lib.nix75
1 files changed, 38 insertions, 37 deletions
diff --git a/tests/lib.nix b/tests/lib.nix
index b98be69..2ec42e6 100644
--- a/tests/lib.nix
+++ b/tests/lib.nix
@@ -1,47 +1,48 @@
-{ pkgs ? (import <nixpkgs> {})
+{ pkgs ? (import <nixpkgs> { })
, makeTest ? import <nixpkgs/nixos/tests/make-test-python.nix>
, ...
}:
{
- makeDiskoTest = {
- disko-config,
- extraTestScript,
- extraConfig ? {}
- }:
- let
- lib = pkgs.lib;
- makeTest' = args:
- makeTest args {
- inherit pkgs;
- inherit (pkgs) system;
- };
- tsp-create = pkgs.writeScript "create" ((pkgs.callPackage ../. {}).create disko-config);
- tsp-mount = pkgs.writeScript "mount" ((pkgs.callPackage ../. {}).mount disko-config);
- num-disks = builtins.length (builtins.filter (x: builtins.match "vd." x == []) (lib.attrNames disko-config.content));
- in makeTest' {
- name = "disko";
+ makeDiskoTest =
+ { disko-config
+ , extraTestScript
+ , extraConfig ? { }
+ }:
+ let
+ lib = pkgs.lib;
+ makeTest' = args:
+ makeTest args {
+ inherit pkgs;
+ inherit (pkgs) system;
+ };
+ tsp-create = pkgs.writeScript "create" ((pkgs.callPackage ../. { }).create disko-config);
+ tsp-mount = pkgs.writeScript "mount" ((pkgs.callPackage ../. { }).mount disko-config);
+ num-disks = builtins.length (builtins.filter (x: builtins.match "vd." x == [ ]) (lib.attrNames disko-config.content));
+ in
+ makeTest' {
+ name = "disko";
- nodes.machine =
- { config, pkgs, modulesPath, ... }:
+ nodes.machine =
+ { config, pkgs, modulesPath, ... }:
- {
- imports = [
- (modulesPath + "/profiles/installation-device.nix")
- (modulesPath + "/profiles/base.nix")
- ];
+ {
+ imports = [
+ (modulesPath + "/profiles/installation-device.nix")
+ (modulesPath + "/profiles/base.nix")
+ ];
- # speed-up eval
- documentation.enable = false;
+ # speed-up eval
+ documentation.enable = false;
- virtualisation.emptyDiskImages = builtins.genList (_: 512) num-disks;
- } // extraConfig;
+ virtualisation.emptyDiskImages = builtins.genList (_: 512) num-disks;
+ } // extraConfig;
- testScript = ''
- machine.succeed("echo 'secret' > /tmp/secret.key");
- machine.succeed("${tsp-create}");
- machine.succeed("${tsp-mount}");
- machine.succeed("${tsp-mount}"); # verify that the command is idempotent
- ${extraTestScript}
- '';
- };
+ testScript = ''
+ machine.succeed("echo 'secret' > /tmp/secret.key");
+ machine.succeed("${tsp-create}");
+ machine.succeed("${tsp-mount}");
+ machine.succeed("${tsp-mount}"); # verify that the command is idempotent
+ ${extraTestScript}
+ '';
+ };
}