summaryrefslogtreecommitdiffstats
path: root/module.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2022-11-29 14:58:31 +0100
committerJörg Thalheim <joerg@thalheim.io>2022-11-29 15:00:25 +0100
commit67f991e2bcf38d7c2a99f1cdbbdb4fbc60b8e8a0 (patch)
tree0c060cb0aedc6322d7d2130005bcfdd947e03239 /module.nix
parent6c3e0d22e465541b35772ba4a00331f587bc28c5 (diff)
drop environment.systemPackages
Those packages are only used for installation and are not used afterwards. system.build outputs can be used to get them in an installer included.
Diffstat (limited to 'module.nix')
-rw-r--r--module.nix18
1 files changed, 0 insertions, 18 deletions
diff --git a/module.nix b/module.nix
index 47c52dd..9b568be 100644
--- a/module.nix
+++ b/module.nix
@@ -16,26 +16,8 @@ in {
type = lib.types.bool;
default = true;
};
- addScripts = lib.mkOption {
- description = ''
- add disko-create and disko-mount scripts to systemPackages.
- '';
- type = lib.types.bool;
- default = true;
- };
};
config = {
- environment.systemPackages = (lib.optionals cfg.addScripts [
- (pkgs.writers.writeDashBin "disko-create" ''
- export PATH=${lib.makeBinPath (types.diskoLib.packages cfg.devices pkgs)}
- ${types.diskoLib.create cfg.devices}
- '')
- (pkgs.writers.writeDashBin "disko-mount" ''
- export PATH=${lib.makeBinPath (types.diskoLib.packages cfg.devices pkgs)}
- ${types.diskoLib.mount cfg.devices}
- '')
- ]) ++ lib.optionals cfg.enableConfig (types.diskoLib.packages cfg.devices pkgs);
-
system.build.formatScript = pkgs.writers.writeDash "disko-create" ''
export PATH=${lib.makeBinPath (types.diskoLib.packages cfg.devices pkgs)}
${types.diskoLib.create cfg.devices}