summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-08-25 15:16:26 +0200
committerlassulus <lassulus@lassul.us>2022-08-25 23:31:05 +0200
commit0ffaac7913565e497c5193d45fd50de78f3241f0 (patch)
treea8cf1f0043557d7408d8b1ed55fd88028418fe7e /flake.nix
parent83fb8f661eb574f32fad1d51bbebd0c36595db01 (diff)
run all tests on ci
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 3e7263a..488933d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,11 +9,11 @@
};
checks.x86_64-linux = let
pkgs = nixpkgs.legacyPackages.x86_64-linux;
- in {
+ in
# Run tests: nix flake check -L
- nixos-test = pkgs.callPackage ./tests/test.nix {
+ import ./tests {
+ inherit pkgs;
makeTest = import (pkgs.path + "/nixos/tests/make-test-python.nix");
};
- };
};
}