summaryrefslogtreecommitdiffstats
path: root/example/mdadm.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2022-10-04 11:30:22 +0200
committerGitHub <noreply@github.com>2022-10-04 11:30:22 +0200
commitc96ccd7d9fb48b8283e84811c2355a3c39bb2a52 (patch)
tree5cdd04282099d607d86c961e390077b09f50452b /example/mdadm.nix
parent60b5f5e7495dd90b8212d121905feaee313fef8f (diff)
parent9f7f23abdb161578316d94f45528fbf47982f4d9 (diff)
Merge pull request #43 from nix-community/test-config
add nixos tests for disko.config
Diffstat (limited to 'example/mdadm.nix')
-rw-r--r--example/mdadm.nix24
1 files changed, 20 insertions, 4 deletions
diff --git a/example/mdadm.nix b/example/mdadm.nix
index 094499d..8093698 100644
--- a/example/mdadm.nix
+++ b/example/mdadm.nix
@@ -1,13 +1,21 @@
-{
+{ disks ? [ "/dev/vdb" "/dev/vdc" ] }: {
disk = {
vdb = {
type = "disk";
- device = "/dev/vdb";
+ device = builtins.elemAt disks 0;
content = {
type = "table";
format = "gpt";
partitions = [
{
+ name = "boot";
+ type = "partition";
+ start = "0";
+ end = "1M";
+ part-type = "primary";
+ flags = ["bios_grub"];
+ }
+ {
type = "partition";
name = "mdadm";
start = "1MiB";
@@ -22,12 +30,20 @@
};
vdc = {
type = "disk";
- device = "/dev/vdc";
+ device = builtins.elemAt disks 1;
content = {
type = "table";
format = "gpt";
partitions = [
{
+ name = "boot";
+ type = "partition";
+ start = "0";
+ end = "1M";
+ part-type = "primary";
+ flags = ["bios_grub"];
+ }
+ {
type = "partition";
name = "mdadm";
start = "1MiB";
@@ -57,7 +73,7 @@
content = {
type = "filesystem";
format = "ext4";
- mountpoint = "/raid";
+ mountpoint = "/";
};
}
];