summaryrefslogtreecommitdiffstats
path: root/example/btrfs-subvolumes.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2022-08-26 14:59:28 +0100
committerGitHub <noreply@github.com>2022-08-26 14:59:28 +0100
commitadf901d58155ca268d15351fff164d3ef38a0890 (patch)
treec6057a3d362e06742073b35d4c11db7ee9a0a820 /example/btrfs-subvolumes.nix
parent6b0b20da18cdffd09f04faee7128c557bcb9f054 (diff)
parent9bb4aec9640cbc30e241c267158e506278862b5e (diff)
Merge pull request #27 from nix-community/zfs
zfs, lvm raid, btrfs subvolumes support & some fixups
Diffstat (limited to 'example/btrfs-subvolumes.nix')
-rw-r--r--example/btrfs-subvolumes.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/example/btrfs-subvolumes.nix b/example/btrfs-subvolumes.nix
new file mode 100644
index 0000000..0124c86
--- /dev/null
+++ b/example/btrfs-subvolumes.nix
@@ -0,0 +1,26 @@
+{
+ type = "devices";
+ content = {
+ vdb = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ part-type = "primary";
+ start = "0%";
+ end = "100%";
+ content = {
+ type = "btrfs";
+ mountpoint = "/";
+ subvolumes = [
+ "/home"
+ "/test"
+ ];
+ };
+ }
+ ];
+ };
+ };
+}
+