summaryrefslogtreecommitdiffstats
path: root/tv/source.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/source.nix')
-rw-r--r--tv/source.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/tv/source.nix b/tv/source.nix
index f3bda271..b5e3f7cd 100644
--- a/tv/source.nix
+++ b/tv/source.nix
@@ -1,8 +1,10 @@
with import <stockholm/lib>;
-host@{ name, secure ? false, override ? {} }: let
- builder = if getEnv "dummy_secrets" == "true"
- then "buildbot"
- else "tv";
+{ name
+, dummy_secrets ? getEnv "dummy_secrets" == "true"
+, override ? {}
+, secure ? false
+}@host: let
+ builder = if dummy_secrets then "buildbot" else "tv";
_file = <stockholm> + "/tv/1systems/${name}/source.nix";
in
evalSource (toString _file) [
@@ -10,7 +12,7 @@ in
nixos-config.symlink = "stockholm/tv/1systems/${name}/config.nix";
nixpkgs.git = {
# nixos-17.09
- ref = mkDefault "d0f0657ca06cc8cb239cb94f430b53bcdf755887";
+ ref = mkDefault "53e6d671a9662922080635482b7e1c418d2cdc72";
url = https://github.com/NixOS/nixpkgs;
};
secrets.file = getAttr builder {