summaryrefslogtreecommitdiffstats
path: root/tv/2configs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/default.nix')
-rw-r--r--tv/2configs/default.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/tv/2configs/default.nix b/tv/2configs/default.nix
index c4a2d6ba..5a1e90bc 100644
--- a/tv/2configs/default.nix
+++ b/tv/2configs/default.nix
@@ -40,8 +40,8 @@ with config.krebs.lib;
mutableUsers = false;
users = {
tv = {
+ inherit (config.krebs.users.tv) home uid;
isNormalUser = true;
- uid = 1337;
extraGroups = [ "tv" ];
};
};
@@ -50,6 +50,7 @@ with config.krebs.lib;
{
security.sudo.extraConfig = ''
Defaults mailto="${config.krebs.users.tv.mail}"
+ Defaults !lecture
'';
time.timeZone = "Europe/Berlin";
}
@@ -123,7 +124,7 @@ with config.krebs.lib;
0)
PS1='\[\e[1;31m\]\w\[\e[0m\] '
;;
- 1337)
+ ${toString config.krebs.users.tv.uid})
PS1='\[\e[1;32m\]\w\[\e[0m\] '
;;
*)