summaryrefslogtreecommitdiffstats
path: root/tv/2configs/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/2configs/base.nix')
-rw-r--r--tv/2configs/base.nix13
1 files changed, 9 insertions, 4 deletions
diff --git a/tv/2configs/base.nix b/tv/2configs/base.nix
index 010d4b32..0a8dbdcc 100644
--- a/tv/2configs/base.nix
+++ b/tv/2configs/base.nix
@@ -15,6 +15,12 @@ in
imports = [
{
+ # stockholm dependencies
+ environment.systemPackages = with pkgs; [
+ git
+ ];
+ }
+ {
# TODO never put hashedPassword into the store
users.extraUsers =
mapAttrs (_: h: { hashedPassword = h; })
@@ -147,10 +153,9 @@ in
}
{
- nixpkgs.config.packageOverrides = pkgs:
- {
- nano = pkgs.runCommand "empty" {} "mkdir -p $out";
- };
+ nixpkgs.config.packageOverrides = pkgs: {
+ nano = pkgs.vim;
+ };
services.cron.enable = false;
services.nscd.enable = false;