summaryrefslogtreecommitdiffstats
path: root/tv/1systems/wu.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/1systems/wu.nix')
-rw-r--r--tv/1systems/wu.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/tv/1systems/wu.nix b/tv/1systems/wu.nix
index 6cd1565f..17394df2 100644
--- a/tv/1systems/wu.nix
+++ b/tv/1systems/wu.nix
@@ -8,16 +8,18 @@ with lib;
krebs.build.target = "root@wu";
- krebs.build.deps = {
- nixpkgs = {
- url = https://github.com/4z3/nixpkgs;
- rev = "03130ec91356cd250b80f144022ee2f4d665ca36"; # 1357692
+ krebs.build.source = {
+ git.nixpkgs = {
+ url = https://github.com/NixOS/nixpkgs;
+ rev = "bd84ebaa1e0359f41350e053ed24592b169b5714";
};
- secrets = {
- url = "/home/tv/secrets/${config.krebs.build.host.name}";
+ dir.secrets = {
+ host = config.krebs.hosts.wu;
+ path = "/home/tv/secrets/wu";
};
- stockholm = {
- url = toString ../..;
+ dir.stockholm = {
+ host = config.krebs.hosts.wu;
+ path = "/home/tv/stockholm";
};
};
@@ -71,6 +73,7 @@ with lib;
cac
dic
file
+ get
gitAndTools.qgit
gnupg21
haskellPackages.hledger
@@ -213,7 +216,6 @@ with lib;
extraGroups = [
"audio"
"video"
- "bumblebee"
];
};
@@ -254,7 +256,6 @@ with lib;
extraGroups = [
"audio"
"video"
- "bumblebee"
];
};
@@ -263,7 +264,6 @@ with lib;
extraGroups = [
"audio"
"video"
- "bumblebee"
];
};
@@ -331,6 +331,7 @@ with lib;
};
"/home" = {
device = "/dev/mapper/home";
+ fsType = "btrfs";
options = "defaults,noatime,ssd,compress=lzo";
};
"/boot" = {