summaryrefslogtreecommitdiffstats
path: root/shared/2configs/repo-sync.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shared/2configs/repo-sync.nix')
-rw-r--r--shared/2configs/repo-sync.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shared/2configs/repo-sync.nix b/shared/2configs/repo-sync.nix
new file mode 100644
index 00000000..b23cb167
--- /dev/null
+++ b/shared/2configs/repo-sync.nix
@@ -0,0 +1,28 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ krebs.repo-sync = let
+ # TODO addMirrorURL function
+ mirror = "git@wolf:stockholm-mirror";
+ in {
+ enable = true;
+ config = {
+ makefu = {
+ origin.url = http://cgit.gum/stockholm ;
+ mirror.url = mirror;
+ };
+ tv = {
+ origin.url = http://cgit.cd/stockholm ;
+ mirror.url = mirror;
+ };
+ lassulus = {
+ origin.url = http://cgit.cloudkrebs/stockholm ;
+ mirror.url = mirror;
+ };
+ "@latest" = {
+ mirror.url = mirror;
+ };
+ };
+ };
+}