summaryrefslogtreecommitdiffstats
path: root/modules/tv/iptables/options.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/tv/iptables/options.nix')
-rw-r--r--modules/tv/iptables/options.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/modules/tv/iptables/options.nix b/modules/tv/iptables/options.nix
deleted file mode 100644
index 1adffebd..00000000
--- a/modules/tv/iptables/options.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ lib, ... }:
-
-let
- inherit (lib) mkOption types;
-in
-
-{
- enable = mkOption {
- type = types.bool;
- default = false;
- description = "Enable iptables.";
- };
-
- input-internet-accept-new-tcp = mkOption {
- type = with types; listOf str;
- default = [];
- description = ''
- TCP ports, accepting incoming connections from anywhere.
- '';
- };
-
- input-retiolum-accept-new-tcp = mkOption {
- type = with types; listOf str;
- default = [];
- description = ''
- TCP ports, accepting incoming connections from Retiolum.
- '';
- };
-}