summaryrefslogtreecommitdiffstats
path: root/modules/tv/git/cgit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/tv/git/cgit.nix')
-rw-r--r--modules/tv/git/cgit.nix11
1 files changed, 1 insertions, 10 deletions
diff --git a/modules/tv/git/cgit.nix b/modules/tv/git/cgit.nix
index fd87b908..826ee7f2 100644
--- a/modules/tv/git/cgit.nix
+++ b/modules/tv/git/cgit.nix
@@ -1,23 +1,15 @@
-{ config, lib, pkgs, ... }:
+{ cfg, config, lib, pkgs, ... }:
let
inherit (builtins) attrValues filter getAttr;
inherit (lib) concatMapStringsSep mkIf optionalString;
- cfg = config.services.git;
-
location = lib.nameValuePair; # TODO this is also in modules/wu/default.nix
isPublicRepo = getAttr "public"; # TODO this is also in ./default.nix
in
{
- imports = [
- ../../tv/nginx
- ];
-
- config = mkIf cfg.cgit {
-
users.extraUsers = lib.singleton {
name = "fcgiwrap";
uid = 2851179180; # genid fcgiwrap
@@ -93,5 +85,4 @@ in
'')
];
};
- };
}