summaryrefslogtreecommitdiffstats
path: root/modules/cd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/cd/default.nix')
-rw-r--r--modules/cd/default.nix33
1 files changed, 20 insertions, 13 deletions
diff --git a/modules/cd/default.nix b/modules/cd/default.nix
index ac32795e..7223203a 100644
--- a/modules/cd/default.nix
+++ b/modules/cd/default.nix
@@ -59,31 +59,38 @@
makefu = { pubkey = "xxx"; };
};
- # TODO warn about stale repodirs
repos = addNames {
+ shitment = {
+ desc = "shitment repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
testing = {
+ desc = "testing repository";
hooks = {
- update = ''
- #! /bin/sh
- set -euf
- echo update hook: $* >&2
- '';
- post-update = ''
- #! /bin/sh
- set -euf
- echo post-update hook: $* >&2
- '';
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#repository";
+ server = "ire.retiolum";
+ };
};
+ public = true;
};
};
rules = with git; with users; with repos; [
{ user = tv;
- repo = testing;
+ repo = [ testing shitment ];
perm = push master [ non-fast-forward create delete merge ];
}
{ user = [ lass makefu ];
- repo = testing;
+ repo = [ testing shitment ];
perm = fetch;
}
];