summaryrefslogtreecommitdiffstats
path: root/makefu/source.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/source.nix')
-rw-r--r--makefu/source.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/makefu/source.nix b/makefu/source.nix
new file mode 100644
index 00000000..a24af4df
--- /dev/null
+++ b/makefu/source.nix
@@ -0,0 +1,38 @@
+with import <stockholm/lib>;
+host@{ name, secure ? false, override ? {}, full ? false }: let
+ builder = if getEnv "dummy_secrets" == "true"
+ then "buildbot"
+ else "makefu";
+ _file = <stockholm> + "/makefu/1systems/${name}/source.nix";
+ ref = "06734d1"; # unstable @ 2017-07-03 + graceful requests2 (a772c3aa)
+
+in
+ evalSource (toString _file) [
+ {
+ nixos-config.symlink = "stockholm/makefu/1systems/${name}/config.nix";
+ # always perform a full populate when buildbot
+ nixpkgs = if full || (builder == "buildbot" ) then {
+ git = {
+ url = https://github.com/makefu/nixpkgs;
+ inherit ref;
+ };
+ } else {
+ # TODO use http, once it is implemented
+ # right now it is simply extracted revision folder
+
+ ## prepare so we do not have to wait for rsync:
+ ## cd /var/src; curl https://github.com/nixos/nixpkgs/tarball/125ffff -L | tar zx && mv NixOS-nixpkgs-125ffff nixpkgs
+ file = "/home/makefu/store/${ref}";
+ };
+
+ secrets.file = getAttr builder {
+ buildbot = toString <stockholm/makefu/6tests/data/secrets>;
+ makefu = "/home/makefu/secrets/${name}";
+ };
+ stockholm.file = toString <stockholm>;
+ }
+ (mkIf (builder == "makefu") {
+ secrets-common.file = "/home/makefu/secrets/common";
+ })
+ override
+ ]