summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/awesomecfg
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/5pkgs/awesomecfg')
-rw-r--r--makefu/5pkgs/awesomecfg/default.nix4
-rw-r--r--makefu/5pkgs/awesomecfg/full.cfg21
2 files changed, 20 insertions, 5 deletions
diff --git a/makefu/5pkgs/awesomecfg/default.nix b/makefu/5pkgs/awesomecfg/default.nix
index 1ae2f50d..acbe61f3 100644
--- a/makefu/5pkgs/awesomecfg/default.nix
+++ b/makefu/5pkgs/awesomecfg/default.nix
@@ -6,15 +6,17 @@
, blueman
, clipit
, flameshot
+, chapter-marker
, modkey ? "Mod4"
, locker? "${pkgs.xlock}/bin/xlock -mode blank"
, ... }:
{
- # replace: @alsaUtils@ @xlockmore@ @xbacklight@ @modkey@
+ # replace: @alsaUtils@ @xlockmore@ @xbacklight@ @modkey@ @chapter-marker@
full = lib.makeOverridable pkgs.substituteAll {
name = "awesome_full_config";
inherit alsaUtils locker xbacklight modkey networkmanagerapplet blueman clipit flameshot ;
+ chaptermarker = chapter-marker;
isExecutable = false;
src = ./full.cfg;
};
diff --git a/makefu/5pkgs/awesomecfg/full.cfg b/makefu/5pkgs/awesomecfg/full.cfg
index d96b61ad..86b401cf 100644
--- a/makefu/5pkgs/awesomecfg/full.cfg
+++ b/makefu/5pkgs/awesomecfg/full.cfg
@@ -376,6 +376,12 @@ globalkeys = awful.util.table.join(
awful.key({ }, "XF86AudioMute", function ()
awful.util.spawn("@alsaUtils@/bin/amixer -q -D default sset Master toggle", false) end),
+ -- chapter-marker
+ awful.key({ "Control" }, "u", function () awful.spawn("@chaptermarker@/bin/chapter-start") end,
+ {description = "start the chapter marker",}),
+ awful.key({ "Control" }, "j", function () awful.spawn("@chaptermarker@/bin/chapter-mark") end,
+ {description = "create a chapter mark",}),
+
-- Prompt
awful.key({ modkey }, "r", function () awful.screen.focused().mypromptbox:run() end,
{description = "run prompt", group = "launcher"}),
@@ -492,9 +498,16 @@ awful.rules.rules = {
properties = { floating = true } },
--{ rule = { class = "gimp" },
-- properties = { floating = true } },
- -- Set Firefox to always map on tags number 2 of screen 1.
- -- { rule = { class = "Firefox" },
- -- properties = { tag = tags[1][2] } },
+ { rule = { class = "Firefox" },
+ properties = { tag = tags[3] } },
+ { rule = { class = "signal-desktop" },
+ properties = { tag = tags[4] } },
+ { rule = { class = "telegram-desktop" },
+ properties = { tag = tags[4] } },
+ { rule = { class = "mutt" },
+ properties = { tag = tags[5] } },
+ { rule = { class = "mosh" },
+ properties = { tag = tags[2] } },
}
-- }}}
@@ -569,7 +582,7 @@ local os = {
-- {{{ autostart
do
- awful.spawn("urxvt", { tag = tags[1] }) -- dev shell
+ -- awful.spawn("urxvt", { tag = tags[1] }) -- dev shell
awful.spawn("urxvt -e mosh makefu@gum.i", { tag = tags[2] })
awful.spawn("firefox", { tag = tags[3] })
awful.spawn("telegram-desktop", { tag = tags[4] })