summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/tools/core.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/tools/core.nix')
-rw-r--r--makefu/2configs/tools/core.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/makefu/2configs/tools/core.nix b/makefu/2configs/tools/core.nix
new file mode 100644
index 00000000..86d72c66
--- /dev/null
+++ b/makefu/2configs/tools/core.nix
@@ -0,0 +1,46 @@
+{ pkgs, ... }:
+
+# tools i use when actually working with the host.
+# package version will now be maintained by nix-rebuild
+#
+# essentially `nix-env -q` of the main user
+{
+ krebs.per-user.makefu.packages = with pkgs; [
+ at_spi2_core
+ acpi
+ bc
+ rsync
+ exif
+ file
+ ntfs3g
+ pv
+ proot
+ sshpass
+ populate
+ usbutils
+ p7zip
+ hdparm
+ inetutils
+ ncftp
+ mutt
+ tcpdump
+ sysstat
+ which
+ weechat
+ curl
+ wget
+ wol
+ tmux
+ smartmontools
+ cifs-utils
+ iftop
+ taskwarrior
+ mplayer
+
+ cac-api
+ cac-panel
+ krebspaste
+ ledger
+ pass
+ ];
+}