summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/rtorrent.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/rtorrent.nix')
-rw-r--r--makefu/2configs/rtorrent.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/makefu/2configs/rtorrent.nix b/makefu/2configs/rtorrent.nix
new file mode 100644
index 00000000..d024ded9
--- /dev/null
+++ b/makefu/2configs/rtorrent.nix
@@ -0,0 +1,13 @@
+_:
+let
+ listenPort = 60123;
+ xml-port = 5000;
+in {
+ makefu.rtorrent = {
+ enable = true;
+ web.enable = true;
+ xmlrpc = "localhost:${toString xml-port}";
+ logLevel = "debug";
+ inherit listenPort;
+ };
+}