summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/laptop-utils.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/laptop-utils.nix')
-rw-r--r--makefu/2configs/laptop-utils.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/makefu/2configs/laptop-utils.nix b/makefu/2configs/laptop-utils.nix
index b5ba2ec3..815ff748 100644
--- a/makefu/2configs/laptop-utils.nix
+++ b/makefu/2configs/laptop-utils.nix
@@ -6,7 +6,11 @@
# essentially `nix-env -q` of the main user
# TODO: split gui and non-gui
{
- environment.systemPackages = with pkgs; [
+ nixpkgs.config.firefox = {
+ enableAdobeFlash = true;
+ };
+
+ krebs.per-user.makefu.packages = with pkgs; [
# core
at_spi2_core
acpi
@@ -27,11 +31,14 @@
# gui
+ chromium
clipit
feh
+ firefox
keepassx
pcmanfm
skype
+ mirage
tightvnc
gnome3.dconf
vlc
@@ -39,10 +46,6 @@
wireshark
xdotool
- # browser
- firefox
- chromium
-
# sectools
aria2
binwalk
@@ -53,10 +56,10 @@
# stuff
- cac-cli
+ cac-api
cac-panel
krebspaste
ledger
- password-store
+ pass
];
}