summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/laptop-utils.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/laptop-utils.nix')
-rw-r--r--makefu/2configs/laptop-utils.nix65
1 files changed, 65 insertions, 0 deletions
diff --git a/makefu/2configs/laptop-utils.nix b/makefu/2configs/laptop-utils.nix
new file mode 100644
index 00000000..815ff748
--- /dev/null
+++ b/makefu/2configs/laptop-utils.nix
@@ -0,0 +1,65 @@
+{ pkgs, ... }:
+
+# tools i use when actually working with the host.
+# package version will now be maintained by nix-rebuild
+#
+# essentially `nix-env -q` of the main user
+# TODO: split gui and non-gui
+{
+ nixpkgs.config.firefox = {
+ enableAdobeFlash = true;
+ };
+
+ krebs.per-user.makefu.packages = with pkgs; [
+ # core
+ at_spi2_core
+ acpi
+ bc
+ exif
+ file
+ ntfs3g
+ pv
+ proot
+ sshpass
+ unzip
+ unrar
+ usbutils
+ zip
+
+ # dev
+ python35Packages.virtualenv
+
+
+ # gui
+ chromium
+ clipit
+ feh
+ firefox
+ keepassx
+ pcmanfm
+ skype
+ mirage
+ tightvnc
+ gnome3.dconf
+ vlc
+ virtmanager
+ wireshark
+ xdotool
+
+ # sectools
+ aria2
+ binwalk
+ dnsmasq
+ iodine
+ mtr
+ nmap
+
+
+ # stuff
+ cac-api
+ cac-panel
+ krebspaste
+ ledger
+ pass
+ ];
+}