summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/gui/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/gui/base.nix')
-rw-r--r--makefu/2configs/gui/base.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/makefu/2configs/gui/base.nix b/makefu/2configs/gui/base.nix
index 4ae816d5..b2192c7f 100644
--- a/makefu/2configs/gui/base.nix
+++ b/makefu/2configs/gui/base.nix
@@ -17,8 +17,10 @@ in
{
imports = [
./urxvtd.nix
+ ./pipewire.nix
];
+
services.xserver = {
enable = true;
layout = "us";
@@ -49,7 +51,7 @@ in
};
users.users.${mainUser} = {
- extraGroups = [ "audio" ];
+ extraGroups = [ "pipewire" "audio" ];
packages = with pkgs;[
pavucontrol
xlockmore
@@ -57,10 +59,6 @@ in
];
};
- hardware.pulseaudio = {
- enable = true;
- # systemWide = true;
- };
services.xserver.displayManager.sessionCommands = let
xdefaultsfile = pkgs.writeText "Xdefaults" ''
cat |derp <<EOF
@@ -79,6 +77,7 @@ in
URxvt.urgentOnBell: true
URxvt.visualBell: false
URxvt.font : xft:Terminus:size=12
+ URxvt.perl-ext-common: default,-confirm-paste
! blue