summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/graphite-web.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/graphite-web.nix')
-rw-r--r--makefu/2configs/graphite-web.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/makefu/2configs/graphite-web.nix b/makefu/2configs/graphite-web.nix
new file mode 100644
index 00000000..daa1d49a
--- /dev/null
+++ b/makefu/2configs/graphite-web.nix
@@ -0,0 +1,24 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ imports = [ ];
+ services.graphite = {
+ web = {
+ enable = true;
+ host = "0.0.0.0";
+ };
+ carbon = {
+ enableCache = true;
+ storageSchemas = ''
+ [carbon]
+ pattern = ^carbon\.
+ retentions = 60:90d
+
+ [default]
+ pattern = .*
+ retentions = 60s:30d,300s:1y
+ '';
+ };
+ };
+}