summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/fs/sda-crypto-root-home.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/fs/sda-crypto-root-home.nix')
-rw-r--r--makefu/2configs/fs/sda-crypto-root-home.nix30
1 files changed, 8 insertions, 22 deletions
diff --git a/makefu/2configs/fs/sda-crypto-root-home.nix b/makefu/2configs/fs/sda-crypto-root-home.nix
index 3821c750..cc2133a4 100644
--- a/makefu/2configs/fs/sda-crypto-root-home.nix
+++ b/makefu/2configs/fs/sda-crypto-root-home.nix
@@ -3,37 +3,23 @@
# ssd #
# sda: bootloader grub2
# sda1: boot ext4 (label nixboot)
-# sda2: cryptoluks -> lvm:
-# / (main-root)
-# /home (main-home)
+# sda2: cryptoluks ->
+# lvm:
+# / (main-root)
+# /home (main-home)
with lib;
{
- boot = {
- loader.grub.enable =true;
- loader.grub.version =2;
- loader.grub.device = "/dev/sda";
- initrd.luks.devices = [ { name = "main"; device = "/dev/sda2"; allowDiscards=true; }];
- initrd.luks.cryptoModules = ["aes" "sha512" "sha1" "xts" ];
- initrd.availableKernelModules = ["xhci_hcd" "ehci_pci" "ahci" "usb_storage" ];
- };
+ imports = [
+ ./sda-crypto-root.nix # configures crypto + boot
+ ];
fileSystems = {
- "/" = {
- device = "/dev/mapper/main-root";
- fsType = "ext4";
- options="defaults,discard";
- };
- # TODO: just import sda-crypto-root, add this device
+ "/".device = lib.mkForce "/dev/mapper/main-root";
"/home" = {
device = "/dev/mapper/main-home";
fsType = "ext4";
options="defaults,discard";
};
- "/boot" = {
- device = "/dev/disk/by-label/nixboot";
- fsType = "ext4";
- options="defaults,discard";
- };
};
}