summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/bgt/social-to-irc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/2configs/bgt/social-to-irc.nix')
-rw-r--r--makefu/2configs/bgt/social-to-irc.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/makefu/2configs/bgt/social-to-irc.nix b/makefu/2configs/bgt/social-to-irc.nix
index dc975c35..8e81f9b5 100644
--- a/makefu/2configs/bgt/social-to-irc.nix
+++ b/makefu/2configs/bgt/social-to-irc.nix
@@ -1,10 +1,17 @@
+{ pkgs, ... }:
{
- # systemd.services.brockman.environment."BROCKMAN_LOG_LEVEL" = "DEBUG";
+ systemd.services.brockman.environment."BROCKMAN_LOG_LEVEL" = "DEBUG";
+ systemd.services.restart-brockman = {
+ after = [ "brockman.service" ];
+ wantedBy = [ "multi-user.target" ];
+ startAt = "daily";
+ script = "${pkgs.systemd}/bin/systemctl try-restart brockman.service";
+ };
krebs.brockman = {
enable = true;
config = {
channel = "#binaergewitter";
- notifyErrors = false;
+ notifyErrors = false;
irc = {
host = "irc.freenode.net";
port = 6667;