summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/x/x13/zfs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'makefu/1systems/x/x13/zfs.nix')
-rw-r--r--makefu/1systems/x/x13/zfs.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/makefu/1systems/x/x13/zfs.nix b/makefu/1systems/x/x13/zfs.nix
new file mode 100644
index 00000000..adfebbf9
--- /dev/null
+++ b/makefu/1systems/x/x13/zfs.nix
@@ -0,0 +1,32 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "nvme" "ehci_pci" "xhci_pci" "rtsx_pci_sdmmc" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-amd" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "zroot/root/nixos";
+ fsType = "zfs";
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/20BF-2755";
+ fsType = "vfat";
+ };
+
+ fileSystems."/home" =
+ { device = "zroot/root/home";
+ fsType = "zfs";
+ };
+
+ swapDevices = [ ];
+}