summaryrefslogtreecommitdiffstats
path: root/lass/2configs/syncthing.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/syncthing.nix')
-rw-r--r--lass/2configs/syncthing.nix23
1 files changed, 4 insertions, 19 deletions
diff --git a/lass/2configs/syncthing.nix b/lass/2configs/syncthing.nix
index 7758b860..e288df68 100644
--- a/lass/2configs/syncthing.nix
+++ b/lass/2configs/syncthing.nix
@@ -1,20 +1,11 @@
-{ config, pkgs, ... }: with import <stockholm/lib>; let
- all_peers = filterAttrs (n: v: v.syncthing.id != null) config.krebs.hosts;
- own_peers = filterAttrs (n: v: v.owner.name == "lass") all_peers;
- mk_peers = mapAttrs (n: v: { id = v.syncthing.id; });
-in {
+{ config, pkgs, ... }: with import <stockholm/lib>;
+{
+ imports = [ <stockholm/krebs/2configs/syncthing.nix> ];
services.syncthing = {
- enable = true;
group = "syncthing";
- configDir = "/var/lib/syncthing";
declarative = {
key = toString <secrets/syncthing.key>;
cert = toString <secrets/syncthing.cert>;
- devices = mk_peers all_peers;
- folders."/home/lass/sync" = {
- devices = attrNames (filterAttrs (n: v: n != "phone") own_peers);
- # ignorePerms = false;
- };
};
};
krebs.iptables.tables.filter.INPUT.rules = [
@@ -26,11 +17,5 @@ in {
${pkgs.coreutils}/bin/chmod a+x /home/lass
'';
- krebs.permown."/home/lass/sync" = {
- file-mode = "u+rw,g+rw";
- owner = "lass";
- group = "syncthing";
- umask = "0002";
- keepGoing = true;
- };
+ boot.kernel.sysctl."fs.inotify.max_user_watches" = 524288;
}