summaryrefslogtreecommitdiffstats
path: root/lass/2configs/git.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/git.nix')
-rw-r--r--lass/2configs/git.nix8
1 files changed, 6 insertions, 2 deletions
diff --git a/lass/2configs/git.nix b/lass/2configs/git.nix
index d3f5d1f3..61a352bd 100644
--- a/lass/2configs/git.nix
+++ b/lass/2configs/git.nix
@@ -34,6 +34,10 @@ let
cgit.desc = "take a rss feed and a timeout and print it to stdout";
cgit.section = "software";
};
+ nixpkgs = {
+ cgit.desc = "nixpkgs fork";
+ cgit.section = "configuration";
+ };
stockholm = {
cgit.desc = "take all the computers hostage, they'll love you!";
cgit.section = "configuration";
@@ -80,7 +84,7 @@ let
public = true;
};
- make-restricted-repo = name: { collaborators ? [], announce ? false, ... }: {
+ make-restricted-repo = name: { collaborators ? [], announce ? false, hooks ? {}, ... }: {
inherit collaborators name;
public = false;
hooks = optionalAttrs announce {
@@ -93,7 +97,7 @@ let
# TODO define branches in some kind of option per repo
branches = [ "master" "staging*" ];
};
- };
+ } // hooks;
};
make-rules =