summaryrefslogtreecommitdiffstats
path: root/lass/2configs/downloading.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/2configs/downloading.nix')
-rw-r--r--lass/2configs/downloading.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/lass/2configs/downloading.nix b/lass/2configs/downloading.nix
index 5052da5c..553a3a55 100644
--- a/lass/2configs/downloading.nix
+++ b/lass/2configs/downloading.nix
@@ -1,5 +1,6 @@
-{ config, pkgs, ... }:
+{ config, lib, pkgs, ... }:
+with lib;
{
imports = [
../3modules/folderPerms.nix
@@ -10,9 +11,13 @@
name = "download";
home = "/var/download";
createHome = true;
+ useDefaultShell = true;
extraGroups = [
"download"
];
+ openssh.authorizedKeys.keys = map readFile [
+ ../../krebs/Zpubkeys/lass.ssh.pub
+ ];
};
transmission = {
@@ -43,6 +48,7 @@
rpc-username = "download";
#add rpc-password in secrets
rpc-password = "test123";
+ peer-port = 51413;
};
};
@@ -50,6 +56,8 @@
enable = true;
tables.filter.INPUT.rules = [
{ predicate = "-p tcp --dport 9091"; target = "ACCEPT"; }
+ { predicate = "-p tcp --dport 51413"; target = "ACCEPT"; }
+ { predicate = "-p udp --dport 51413"; target = "ACCEPT"; }
];
};